Polybios and Designer don't play well together

Discuss PDF file handling with the Polybios plugin here
Post Reply
User avatar
jPV
Posts: 279
Joined: Sat Mar 26, 2016 10:44 am
Location: RNO
Contact:

Polybios and Designer don't play well together

Post by jPV » Sun Sep 09, 2018 10:06 am

If I have Polybios installed to LIBS:Hollywood/ and I start Designer, it gives an error telling "Error while loading plugin "polybios.hwp": This plugin requires at least Hollywood 7.1!", which is normal for few other plugins too, but the actual problem is that with Polybios I get a hit in the MorphOS debug log. Other non-working plugins don't hit, so I guess there's something broken with Polybios in this regard. Here is the log.

User avatar
airsoftsoftwair
Posts: 3185
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Polybios and Designer don't play well together

Post by airsoftsoftwair » Mon Sep 10, 2018 10:46 pm

Right, that's definitely a bug and doesn't only affect Designer but also executables compiled by Hollywood < 6.0. I'll try to fix this soon.

User avatar
airsoftsoftwair
Posts: 3185
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Polybios and Designer don't play well together

Post by airsoftsoftwair » Fri May 17, 2019 7:26 pm

Code: Select all

- Fix [Amiga]: Polybios didn't exit cleanly when opened by hosts that use a pre-Hollywood 6.0 plugin
  interface (e.g. Hollywood Designer or executables compiled by Hollywood < 6.0)

User avatar
airsoftsoftwair
Posts: 3185
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Polybios and Designer don't play well together

Post by airsoftsoftwair » Mon Jun 24, 2019 5:03 pm

Please update to Polybios 1.1 to fix this nuisance.

Post Reply