Apk compiler error

Please post anything related to the Hollywood APK Compiler here
amyren
Posts: 352
Joined: Thu May 02, 2019 11:53 am

Re: Apk compiler error

Post by amyren »

Thanks anyway.
My main reason for wanting to read the file was that I couldnt locate my keystore password that I made long time ago.
Luckily I found an older installation with apk complier 3.2 and was able to recreate it from that prefs file.

The old prefs file form 3.2 is only partly readable as plain text, but now after modifying it with 4.4 it as all readable, even the password part.
amyren
Posts: 352
Joined: Thu May 02, 2019 11:53 am

Re: Apk compiler error

Post by amyren »

Upon rebuilding my apk compiler preferences I did not remember what gradle version I had in my old settings, but I found that I had version 5.6.2, 6.8 and 7.6 on my disk. I selected 7.6 and it seem to compile just fine.
However, I went to look in the docs and there it says the compiler only works with 6.7.1.
Is still true for the latest compiler 4.4?
plouf
Posts: 449
Joined: Sun Feb 04, 2018 11:51 pm
Location: Athens,Greece

Re: Apk compiler error

Post by plouf »

it may work with other versions but Andreas test it for 6.7.1 :).
you can download 6.7.1 in a separate folder no need to unistall or modify the rest tools
Christos
User avatar
airsoftsoftwair
Posts: 5410
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Apk compiler error

Post by airsoftsoftwair »

amyren wrote: Sun Nov 26, 2023 3:51 pm The old prefs file form 3.2 is only partly readable as plain text, but now after modifying it with 4.4 it as all readable, even the password part.
Yes, newer APK Compiler use JSON instead of a custom format for storing the prefs so I should add some encryption for the password :)
Post Reply