hURL and newer SSL implementations

Discuss about plugins that don't have a dedicated forum
Post Reply
User avatar
jPV
Posts: 613
Joined: Sat Mar 26, 2016 10:44 am
Location: RNO
Contact:

hURL and newer SSL implementations

Post by jPV »

OpenSSL 1.x is getting older and some issues are raising that are fixed in the latest OpenSSL 3.x versions, are there plans to update the underlying SSL engines on the hURL plugin now that we have native OpenSSL 3.x libraries for Amiga compatible platforms too?

AmiSSL v5 was just released and it has the full compatibility with OpenSSL 3.0 for 68k/OS4. The latest MorphOS distributions also have the openssl3.library for a native solution, which should be better than an emulated solution in every aspect.
User avatar
airsoftsoftwair
Posts: 5474
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: hURL and newer SSL implementations

Post by airsoftsoftwair »

Yes, that's definitely on the agenda.
User avatar
midwan
Posts: 74
Joined: Sun Jun 19, 2016 1:15 pm
Location: Sweden

Re: hURL and newer SSL implementations

Post by midwan »

Any news on this?

It would be great to get hURL recompiled to use the newer AmiSSL 5.x version
User avatar
jPV
Posts: 613
Joined: Sat Mar 26, 2016 10:44 am
Location: RNO
Contact:

Re: hURL and newer SSL implementations

Post by jPV »

I could also update several programs with a new hURL version :) No pressure, just saying and hoping it's not too low on priority ;)
User avatar
midwan
Posts: 74
Joined: Sun Jun 19, 2016 1:15 pm
Location: Sweden

Re: hURL and newer SSL implementations

Post by midwan »

Is it currently using AmiSSL v1?

The documentation mentions it requires AmiSSL 4, but SnoopDOS indicates it's trying to open AmiSSL v1 library instead. And I've had a few users reporting that even though they had AmiSSL 4.x installed, it still didn't work for them.
User avatar
jPV
Posts: 613
Joined: Sat Mar 26, 2016 10:44 am
Location: RNO
Contact:

Re: hURL and newer SSL implementations

Post by jPV »

It is using AmiSSL v4... maybe users have installed different AmiSSL versions next to each other and they don't have up-to-date amisslmaster.library anymore? It should be from the latest release always...
User avatar
midwan
Posts: 74
Joined: Sun Jun 19, 2016 1:15 pm
Location: Sweden

Re: hURL and newer SSL implementations

Post by midwan »

jPV wrote: Mon Apr 03, 2023 3:57 pm It is using AmiSSL v4... maybe users have installed different AmiSSL versions next to each other and they don't have up-to-date amisslmaster.library anymore? It should be from the latest release always...
Alright, thanks for verifying. I'm planning to set up a fresh AmigaOS installation to test which exact requirements are needed, so I can update my documentation accordingly.
User avatar
jPV
Posts: 613
Joined: Sat Mar 26, 2016 10:44 am
Location: RNO
Contact:

Re: hURL and newer SSL implementations

Post by jPV »

One thing that came in my mind... I got one report that hURL or AmiSSL doesn't work with an old bsdsocket.library. So if users have a freeware AmiTCP/IP (3.x or so), then it doesn't work. Something requires bsdsocket.library from AmiTCP/IP v4 or newer stacks IIRC.
User avatar
airsoftsoftwair
Posts: 5474
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: hURL and newer SSL implementations

Post by airsoftsoftwair »

Code: Select all

- New [OS3/OS4]: hURL uses AmiSSL 5 instead of AmiSSL 4 now
- Change [MorphOS]: hURL on MorphOS doesn't use AmiSSL any longer but MorphOS' native implementation of
  OpenSSL 3 (openssl3.library); this means that hURL requires MorphOS 3.16 or better now
Post Reply