apk API version

Please post anything related to the Hollywood APK Compiler here
AlexC
Posts: 25
Joined: Sat Mar 09, 2019 2:40 am

Re: apk API version

Post by AlexC »

@xabierpayet

I haven't tried to upload an apk to the store in a very long time so I don't know. Sorry.
If you get an error message, please post it here or in a new thread for Andreas to look into it.
xabierpayet
Posts: 250
Joined: Fri Feb 24, 2012 9:34 am

Re: apk API version

Post by xabierpayet »

ok, thankyou
amyren
Posts: 301
Joined: Thu May 02, 2019 11:53 am

Re: apk API version

Post by amyren »

Due to the message below I figured I could try to update the android studio components.

Code: Select all

Incompatible Gradle Versions
../../build.gradle:4: The compileSdkVersion (30) should not be lower than the targetSdkVersion (31)
I did also update gradle, the NDK, CMake and the SDK tools.
But with API 31 installed the apk compiler failed to compile at all.

Uninstalling Android API 31 and installing 11.0 again and it does work, with the above error message.
I have not tried installing API 32 or 33 yet, but I guess it will give the same result.

Another strange thing is that after each time I do a change and use "clean current target", the arm8 apk fails to build.
When compiling a second time it will succed.
Post Reply