Setting gradient type bug(?)

Report any Designer bugs here
Post Reply
Ferin
Posts: 18
Joined: Fri May 26, 2017 12:41 am

Setting gradient type bug(?)

Post by Ferin »

Hi there.

It's my first post in here, so first i say hello to everyone.
Now let's get to less pleasent things. I've been told that it's probably not Designer's bug,
but as I use only Designer (can't do any programming so far) so i post it here.

To reproduce bug i found, you have to:
- Create a page
- set gradient to radial or conical
- run script and... gradient is linear.
It seems to affect only page's background. On objects it works as intended.

User avatar
emeck
Posts: 93
Joined: Fri Apr 03, 2015 3:17 pm

Re: Setting gradient type bug(?)

Post by emeck »

Yes, same here. If transition is used to show the page, then gradient is ok, but as soon as the transition is over, the gradient is changed to linear.
PowerBook 5.2 MorphOS 3.13
PowerBook 5.8 MorphOS 3.13
Amiga 1200 BPPC/BVision AOS4.1 FE

User avatar
airsoftsoftwair
Posts: 4325
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Setting gradient type bug(?)

Post by airsoftsoftwair »

Yes, I can confirm this bug too. Will be fixed, thanks for reporting!

As a workaround, you can just create a filled rectangle which covers the entire page and uses the desired gradient settings. Set its display mode to "Background" and move it all the way to the bottom of the z-order.

User avatar
airsoftsoftwair
Posts: 4325
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Setting gradient type bug(?)

Post by airsoftsoftwair »

This was actually a Hollywood bug introduced in 5.3. Fixed now.

Code: Select all

- Fix: CreateGradientBGPic() didn't work with types #RADIAL and #CONICAL; this bug was introduced in
  Hollywood 5.3; it worked before that

Post Reply