VSync Display Problems

Report any Hollywood bugs here
Post Reply
User avatar
fingus
Posts: 152
Joined: Fri Sep 16, 2011 9:53 am

VSync Display Problems

Post by fingus » Tue Jun 19, 2012 12:05 pm

I discover VSync Display Problems when using DIsplayBrushFX under AmigaOS4.1 and Windows XP Pro, it seems Hollywood don´t wait for the VSync.

User avatar
airsoftsoftwair
Posts: 3441
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: VSync Display Problems

Post by airsoftsoftwair » Wed Jun 20, 2012 12:00 am

That's normal. Sync'ing the display requires direct hardware access on Windows through DirectDraw or so that's why Hollywood doesn't do it to keep dependencies and potential error sources as low as possible. On OS4 it's even more difficult because there's no direct support in the OS for perfect sync.

User avatar
fingus
Posts: 152
Joined: Fri Sep 16, 2011 9:53 am

Re: VSync Display Problems

Post by fingus » Wed Jul 04, 2012 3:35 pm

Andreas wrote:That's normal. Sync'ing the display requires direct hardware access on Windows through DirectDraw or so that's why Hollywood doesn't do it to keep dependencies and potential error sources as low as possible. On OS4 it's even more difficult because there's no direct support in the OS for perfect sync.
Does that mean this behaviour is always present in fullscreen and window also and with hardware accelerated brushes?

User avatar
airsoftsoftwair
Posts: 3441
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: VSync Display Problems

Post by airsoftsoftwair » Fri Jul 06, 2012 10:36 pm

Does that mean this behaviour is always present in fullscreen and window also and with hardware accelerated brushes?
Not necessarily. It depends on several factors like speed of the CPU, gfx driver of the host OS, resolution... normally, it should be possible to get a quite smooth experience. The Beast Scroll example is pretty smooth here on all systems I've tested this on.

Post Reply