exe bit not set when compiling to JXFS partition

Report any Hollywood bugs here
Post Reply
User avatar
TheMartian
Posts: 54
Joined: Sun Feb 28, 2010 12:51 pm

exe bit not set when compiling to JXFS partition

Post by TheMartian » Thu Mar 25, 2010 11:59 pm

While testing Codebench SE 0.13 for Hollywood I noticed that whenever I compiled a script the .exe file created would not immediately execute because the execute bit was not set for the created file. I thought it was a quirk in Codebench. But I stand corrected. Codebench works fine. The problem happens whenever I compile to a partition formatted with JXFS and it happens if I use Hollywoods own GUI as well. I have tested three drives with mixed partitions formatted with SFS/00 or JXFS. It is consistent. On JXFS the bit is not set. On SFS/00 it is set. The Hollywood version is 4.5 and I have tested on a SAMFlex 733MHz.

The compiled file can be executed as soon as I set the bit manually.

regards
Jesper

User avatar
airsoftsoftwair
Posts: 3355
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: exe bit not set when compiling to JXFS partition

Post by airsoftsoftwair » Sat Mar 27, 2010 12:48 pm

This seems to be a "feature" of JXFS. Normally, the AmigaOS filesystems always set the executable flag, even if it is a data file. I.e. just try:

Code: Select all

OpenFile(1, "ram:test", #MODE_WRITE)
WriteLine(1, "Hello")
CloseFile(1)
You will see that the file has the E flag set, although it is a data file. So one might say that the JXFS behaviour makes more sense but it of course is not compatible to other Amiga filesystems. I can fix this in Hollywood, though. But as I don't have JXFS installed you need to tell me that flags of newly created files on JXFS. So please run the script above and tell me all attributes that ram:test got from JXFS.

User avatar
TheMartian
Posts: 54
Joined: Sun Feb 28, 2010 12:51 pm

Re: exe bit not set when compiling to JXFS partition

Post by TheMartian » Sat Mar 27, 2010 8:23 pm

Hi

The results from running the test program is as follows:

Writing to the RAM: drive.
Read, Write, Execute and Delete bits set. Archive and script bits not set.

Writing to a JXFS formatted partition:
Read, Write, Delete bits set. Execute, Archive and Script bit not set.

I did change the test program a bit. Tradition requires me to write 'Hello World" instead of just "Hello" :P

regards
Jesper

User avatar
airsoftsoftwair
Posts: 3355
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: exe bit not set when compiling to JXFS partition

Post by airsoftsoftwair » Sun Mar 28, 2010 12:30 pm

Ok, I did some changes now, so that Hollywood will always explicitly set the executable flag so the next version should work fine with JXFS, too :)

Post Reply