Possible bug in DisplayBGPicPart()

Report any Hollywood bugs here
Post Reply
User avatar
Allanon
Posts: 629
Joined: Sun Feb 14, 2010 7:53 pm
Location: Italy
Contact:

Possible bug in DisplayBGPicPart()

Post by Allanon »

Hi Andreas,
there is something strange with DisplayBGPicPart()

If I use the DisplayBGPicPart() with the parameter dy = -1 it does not work, it's not generated an error but the command act like if dy was euql to 0.
For every other values I use (like, 1, -2, 2 and so on) it works fine.

Can you have a look at this?

best regards,
Fabio
----------------------------
[Allanon] Fabio Falcucci
AMC - Creative Development // Docs Site // Support Forum
Support me on Patreon for Hollywood libraries!

User avatar
airsoftsoftwair
Posts: 4243
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Possible bug in DisplayBGPicPart()

Post by airsoftsoftwair »

That's a known issue. I currently have to keep this behaviour because the Malibu plugin uses -1 as a special value to indicate that dstx/y should be equal to srcx/y. Choosing -1 as a 'magic' value was of course not very clever but currently Malibu still relies on it so I have to keep this behaviour.

User avatar
Allanon
Posts: 629
Joined: Sun Feb 14, 2010 7:53 pm
Location: Italy
Contact:

Re: Possible bug in DisplayBGPicPart()

Post by Allanon »

Andreas wrote:That's a known issue. I currently have to keep this behaviour because the Malibu plugin uses -1 as a special value to indicate that dstx/y should be equal to srcx/y. Choosing -1 as a 'magic' value was of course not very clever but currently Malibu still relies on it so I have to keep this behaviour.
Ok, I understand :)
----------------------------
[Allanon] Fabio Falcucci
AMC - Creative Development // Docs Site // Support Forum
Support me on Patreon for Hollywood libraries!

Post Reply