hURL Linking on Linux arm fails

Report any Hollywood bugs here
Post Reply
User avatar
fingus
Posts: 150
Joined: Fri Sep 16, 2011 9:53 am

hURL Linking on Linux arm fails

Post by fingus » Mon May 06, 2019 5:51 pm

On Raspberry pi i got the Error "This Program requires hurl.hwp".

Is linked with:

@REQUIRE "hurl", {Link = True}

in the Sourcecode.

Compiling System is Win10 Pro, with Hollywood 8.0.
I copied it from the C:\Users\user\Downloads\hURL_Linux.tar\hURL_Linux\Plugins\arm

to C:\Program Files\Hollywood\LinkerPlugins\arm-Linux

My Fault or defnitly a Hollywood-Error?

User avatar
airsoftsoftwair
Posts: 3121
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: hURL Linking on Linux arm fails

Post by airsoftsoftwair » Tue May 07, 2019 9:45 pm

Can you post the output that is shown when compiling the executable on Windows 10?

User avatar
fingus
Posts: 150
Joined: Fri Sep 16, 2011 9:53 am

Re: hURL Linking on Linux arm fails

Post by fingus » Wed May 08, 2019 12:40 pm

Update: The same behaviour when Compiling the Beastscroll-Demos with SDL-Plungin Linked on Raspberry-Pi.

Here is the Compiling-Output for my initial Post:

Hollywood 8.0 [Windows] [64-bit] (c) by Andreas Falkenhahn
The Cross-Platform Multimedia Application Layer

Licenced to Niels **********

Loading plugin httpstreamer.hwp...failed
(Reason: Error loading plugin "httpstreamer.hwp"!)
Loading plugin hurl.hwp...done
Loading plugin rapagui.hwp...done
Loading plugin rebelsdl.hwp...done
Loading plugin sid.hwp...done
Loading plugin zip.hwp...done
Opening script Unnamed1.hws...done
Compiling script...done
Creating applet hol1664.tmp...
Linking compiled script...done
Compressing applet...gained 31%
Creating executable Unnamed1.exe...
Linking Hollywood Player [arm-linux]...done
Linking plugin hurl.hwp [arm-linux]...done
Linking applet...done

Linkage successful! Executable size: 2912889 bytes

Information: Hollywood has created a program for Linux [arm]. Note that if you have compiled this executable on a non-Linux system, it will be necessary to set execution permission on the file after you've copied it to your Linux installation or it won't run!

User avatar
airsoftsoftwair
Posts: 3121
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: hURL Linking on Linux arm fails

Post by airsoftsoftwair » Wed May 08, 2019 10:14 pm

Can you try to turn off compression?

User avatar
fingus
Posts: 150
Joined: Fri Sep 16, 2011 9:53 am

Re: hURL Linking on Linux arm fails

Post by fingus » Thu May 09, 2019 9:55 am

airsoftsoftwair wrote:
Wed May 08, 2019 10:14 pm
Can you try to turn off compression?
Same result. Even when i copy the hurl.hwp File to the same Directory it doesn´t find it.

User avatar
airsoftsoftwair
Posts: 3121
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: hURL Linking on Linux arm fails

Post by airsoftsoftwair » Thu May 09, 2019 2:37 pm

Ok, then it's probably missing some dependencies. Do you have OpenSSL installed? If so, which version?

User avatar
fingus
Posts: 150
Joined: Fri Sep 16, 2011 9:53 am

Re: hURL Linking on Linux arm fails

Post by fingus » Thu May 09, 2019 2:42 pm

airsoftsoftwair wrote:
Thu May 09, 2019 2:37 pm
Ok, then it's probably missing some dependencies. Do you have OpenSSL installed? If so, which version?
Host is Windows not Amiga and target ist plain Raspian on RaspPi.

User avatar
airsoftsoftwair
Posts: 3121
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: hURL Linking on Linux arm fails

Post by airsoftsoftwair » Fri May 10, 2019 3:20 pm

Yes, I know but there are dependencies on Linux as well, see:

Code: Select all

$ readelf -d hurl.hwp

Dynamic section at offset 0x76f08 contains 29 entries:
  Tag        Type                         Name/Value
 0x00000001 (NEEDED)                     Shared library: [libssl.so.1.0.0]
 0x00000001 (NEEDED)                     Shared library: [libcrypto.so.1.0.0]
 0x00000001 (NEEDED)                     Shared library: [libz.so.1]
 0x00000001 (NEEDED)                     Shared library: [libpthread.so.0]
 0x00000001 (NEEDED)                     Shared library: [libc.so.6]
 0x0000000e (SONAME)                     Library soname: [hurl.hwp]
 ...
 
libz, libpthread and libc should be available on every system but you must make sure that you have libssl (= OpenSSL) and libcrypto installed or it won't work. It could also be that you have an old version of OpenSSL (e.g. 0.9) installed. You need OpenSSL 1.x.

Post Reply