fillstyle=#FILLGRADIENT stops working with Hollywood 7.1

Report any Hollywood bugs here
Post Reply
User avatar
fingus
Posts: 136
Joined: Fri Sep 16, 2011 9:53 am

fillstyle=#FILLGRADIENT stops working with Hollywood 7.1

Post by fingus » Tue Mar 27, 2018 2:43 pm

SetDisplayAttributes({fillstyle=#FILLGRADIENT, GradientStartColor=$3B6CC5, GradientEndColor=$12093D})

stop working with Hollywood 7.1 on Windows. It just shows a black Background.

User avatar
airsoftsoftwair
Posts: 2626
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany
Contact:

Re: fillstyle=#FILLGRADIENT stops working with Hollywood 7.1

Post by airsoftsoftwair » Mon Apr 02, 2018 9:40 pm

Confirmed. Will be fixed.

User avatar
airsoftsoftwair
Posts: 2626
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany
Contact:

Re: fillstyle=#FILLGRADIENT stops working with Hollywood 7.1

Post by airsoftsoftwair » Mon Apr 16, 2018 6:36 pm

Well, actually, Hollywood 7.1 does things a little different (and better) here than 7.0. On 7.0 SetDisplayAttributes() always reset all gradient attributes which could lead to trouble so Hollywood 7.1 no longer does this. As a result, you cannot rely on any predefined parameters, so you have to explicitly specify all the parameters you need. Concerning your example this means that "GradientStyle" is missing. Thus you have to do the following:

Code: Select all

SetDisplayAttributes({FillStyle=#FILLGRADIENT, GradientStyle=#LINEAR, GradientStartColor=$3B6CC5, GradientEndColor=$12093D})
Then it will work.

User avatar
fingus
Posts: 136
Joined: Fri Sep 16, 2011 9:53 am

Re: fillstyle=#FILLGRADIENT stops working with Hollywood 7.1

Post by fingus » Mon Jul 02, 2018 3:59 pm

It works! Thank you!

Post Reply