libpng security issue

Report any Hollywood bugs here
Post Reply
zylesea
Posts: 204
Joined: Tue Feb 16, 2010 12:50 am
Location: Westfalen/Germany
Contact:

libpng security issue

Post by zylesea » Thu Sep 08, 2016 10:02 am

Google play told me the pnglib used by Hollywood does contain a critical security hole.
From September the 17th google play will not accept programs containing this insecure libpng, but requires a secure version of libpng as V1.0.66, v 1.2.56, v1.4.19 or v1.5.26.

More: https://support.google.com/faqs/answer/7011127

User avatar
airsoftsoftwair
Posts: 3355
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: libpng security issue

Post by airsoftsoftwair » Sun Sep 11, 2016 6:08 pm

Yes, this is a known issue and I've also received those warnings via email. I'll soon release an update of the APK Compiler which addresses this issue.

zylesea
Posts: 204
Joined: Tue Feb 16, 2010 12:50 am
Location: Westfalen/Germany
Contact:

Re: libpng security issue

Post by zylesea » Tue Sep 13, 2016 1:45 am

Good to hear. I am confident you'll fix it.

User avatar
airsoftsoftwair
Posts: 3355
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: libpng security issue

Post by airsoftsoftwair » Tue Sep 20, 2016 6:19 pm

Code: Select all

- Change [Android]: Updated to the latest libpng and zlib versions to make the Play Store's
  vulnerability check happy

Post Reply