Error .mod files on Lubuntu

Report any Hollywood bugs here
Post Reply
divsalv
Posts: 23
Joined: Sun Mar 22, 2015 3:01 am

Error .mod files on Lubuntu

Post by divsalv »

I found error on Lubuntu, which covers .mod file, the problem is that the module starts playing, but then crashes, and the use of cpu is much higher, and the program crashes, but on Ubuntu there is no problem.

Is there any way to solve?

User avatar
airsoftsoftwair
Posts: 4350
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Error .mod files on Lubuntu

Post by airsoftsoftwair »

Which version of Lubuntu are you on? Is the error reproducable with a minimal script that just opens and plays a module?

divsalv
Posts: 23
Joined: Sun Mar 22, 2015 3:01 am

Re: Error .mod files on Lubuntu

Post by divsalv »

Then, the script that I tested is 3D Text included in hollywood, and I use the x86 version 16.4, the latest available from the official website.
But as I said on ubuntu and xubuntu the sound works perfectly, maybe just have to install some packages?

Yes, just play the module file will stop the music, and the prog is crash, so much so that I have to close it from ProcessManager.

User avatar
airsoftsoftwair
Posts: 4350
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Error .mod files on Lubuntu

Post by airsoftsoftwair »

Can't reproduce this here. I've tried to run the 3DText example using the latest x86 Lubuntu live CD and sound works just fine. It has been playing for several minutes now with no problems... or do I have to do something else to reproduce the crash? Just running 3DText doesn't trigger anything here.

divsalv
Posts: 23
Joined: Sun Mar 22, 2015 3:01 am

Re: Error .mod files on Lubuntu

Post by divsalv »

If no one has revealed this error, maybe it's a hardware configuration problem?
With the other formats(mp3,wav, and video) it's all right, it is only in .mod format that has problems.

User avatar
airsoftsoftwair
Posts: 4350
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Error .mod files on Lubuntu

Post by airsoftsoftwair »

That's strange.... MP3, WAV, etc. all use the very same audio driver than the Protracker replayer. Maybe test on another system? Maybe the ALSA driver is faulty with your soundcard. Wouldn't be the first time...

divsalv
Posts: 23
Joined: Sun Mar 22, 2015 3:01 am

Re: Error .mod files on Lubuntu

Post by divsalv »

In the other systems work perfectly, tweety tried on those who possess, Win 10, AmigaOS3.x and 4.1 FE (under WinUAE), aros, linux arm (pi pi raspberry and banana).
Maybe it will be the PC in which I put Lubuntu.

divsalv
Posts: 23
Joined: Sun Mar 22, 2015 3:01 am

Re: Error .mod files on Lubuntu

Post by divsalv »

After the last update the problem seems solved alone, maybe it was just not updated audio driver or ALSA.

Post Reply