apk API version

Please post anything related to the Hollywood APK Compiler here
Post Reply
amyren
Posts: 46
Joined: Thu May 02, 2019 11:53 am

apk API version

Post by amyren » Tue Jul 02, 2019 7:28 pm

I get two warnings when uploading my apk to the google play console
First is that my apk is targeted to API platform 26
secondly it says that the app is not optimized

I can also see that warning in the Lint report created when compiling.

../../build.gradle:9: Not targeting the latest versions of Android; compatibility modes apply. Consider testing and updating this version. Consult the android.os.Build.VERSION_CODES javadoc for details.
6 defaultConfig {
7 applicationId 'com.amy66dev.abandoned'
8 minSdkVersion 14
9 targetSdkVersion 26

10 versionCode 107
11 versionName "1.07"
12 }

For now this is not a problem, but from august 2019, all apps must be targeted to API 28.
Can this be corrected somewhere in a script, or is there something else that needs update?

User avatar
airsoftsoftwair
Posts: 3022
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: apk API version

Post by airsoftsoftwair » Wed Jul 03, 2019 11:31 am

You can ignore all these warnings. As soon as that target requirement is raised to API 28 I'll release an update for the APK Compiler so that you can still get your apps onto the app store.

Post Reply