Page 1 of 2

Gradle fails on set up

Posted: Mon Jun 11, 2018 11:26 pm
by zylesea
Finally I moved from apk compiler 1.x to 2.3.
The first apk compiling fails with a gradle error though.

"ABIs [Armeabi] are not supported fot platform."

"der Befehl gradlew ist entweder falsch geschrieben oder konnte nicht gefunden werden"

See attached screen shot:
Image

Host is a Windows7 system.

Re: Gradle fails on set up

Posted: Wed Jun 13, 2018 5:21 pm
by airsoftsoftwair
Looks like Google removed support for Armeabi from the Android SDK. I'll need to adapt APK Compiler for that.

Re: Gradle fails on set up

Posted: Mon Jun 18, 2018 9:28 pm
by zylesea
Andreas,I think you already know, but new issues by google on the horizon: from August on new apps must meet API 26 criteria (IIRC, currently the apk compiler meets API 14), updates must fullfill API 26 from November on. A kind of debatable* market force "friss oder stirb" policy...

https://developer.android.com/distribut ... target-sdk

* IMHO a warning that an app does meet only older sdk target requirements would be enough, but enforcing the API fullfillment of a certain level is a bit to restrictive IMHO albeit (part of) the intention may be of good reasons (higher security/privacy).

Re: Gradle fails on set up

Posted: Fri Jun 22, 2018 3:27 pm
by airsoftsoftwair
That's no problem because Hollywood's Android backend is currently getting an almost complete rewrite and should be much easier to maintain because more things will be done on the Java side. The current Android backend was mainly written for Android 2.3 and uses NativeActivity as its basis, which, although still supported, is a somewhat dead end road but who could've known that when I wrote the backend 6 years ago? The new backend should make it easier to adapt to changes in the SDK although frequent APK Compiler updates will probably still be necessary because Google changes things all the time here.

Re: Gradle fails on set up

Posted: Sun Jun 24, 2018 11:00 pm
by airsoftsoftwair
The original issue is fixed now by Hollywood APK Compiler 2.4:

Code: Select all

- Change: Dropped support for armeabi architecture because the Android SDK doesn't support it any longer
Download available from the restricted download area.

Re: Gradle fails on set up

Posted: Fri Oct 26, 2018 10:33 pm
by zylesea
airsoftsoftwair wrote:
Fri Jun 22, 2018 3:27 pm
That's no problem because Hollywood's Android backend is currently getting an almost complete rewrite and should be much easier to maintain because more things will be done on the Java side. The current Android backend was mainly written for Android 2.3 and uses NativeActivity as its basis, which, although still supported, is a somewhat dead end road but who could've known that when I wrote the backend 6 years ago? The new backend should make it easier to adapt to changes in the SDK although frequent APK Compiler updates will probably still be necessary because Google changes things all the time here.
How's progress going? No pressure (really not, I am more than impressed by your productive output), just a rough estimate.

Re: Gradle fails on set up

Posted: Fri Oct 26, 2018 11:04 pm
by airsoftsoftwair
Mostly finished, expect some massive improvements on Android in the next Hollywood version. RapaGUI on Android is definitely a game changer!

Re: Gradle fails on set up

Posted: Fri Oct 26, 2018 11:41 pm
by zylesea
You make my mouth watering. Sounds pretty sweet.

Re: Gradle fails on set up

Posted: Mon Nov 19, 2018 12:21 pm
by g0blin
Good morning everyone,

I don't mean to be a pusher here, just waiting for some updates.... :D

Have a nice day

Re: Gradle fails on set up

Posted: Tue Nov 20, 2018 6:34 pm
by airsoftsoftwair
Patience is a virtue ;)