tablet apk and playstore

Please post anything related to the Hollywood APK Compiler here
xabierpayet
Posts: 160
Joined: Fri Feb 24, 2012 10:34 am

tablet apk and playstore

Post by xabierpayet » Wed Dec 07, 2016 1:48 am

hello, if you uploads an apk to the playstore, this is not published for tablets, i can download them only with mobile phones, i tried 5 different apks with different configurations, and i have the same results.
The developer console of google, ever sends to me to the eighth point of this link:
https://developer.android.com/distribut ... d-versions

xabierpayet
Posts: 160
Joined: Fri Feb 24, 2012 10:34 am

Re: tablet apk and playstore

Post by xabierpayet » Wed Dec 07, 2016 1:52 am

i forgot it, here is the link for android, and is called scoreboards
https://play.google.com/store/apps/deta ... oards.dev4

p-OS
Posts: 89
Joined: Tue Nov 02, 2010 12:56 am

Re: tablet apk and playstore

Post by p-OS » Wed Dec 07, 2016 3:19 am

Play Store says, developed for phones.

Nonetheless I can install it und run successfully.

My tablet is a Pipo m6 Pro, running Android 4.2.2, rooted

Screen Resolution is 2048x1536

xabierpayet
Posts: 160
Joined: Fri Feb 24, 2012 10:34 am

Re: tablet apk and playstore

Post by xabierpayet » Wed Dec 07, 2016 3:31 am

i can install it from the web site of the play store, but i don´t found it in the playstore app

p-OS
Posts: 89
Joined: Tue Nov 02, 2010 12:56 am

Re: tablet apk and playstore

Post by p-OS » Wed Dec 07, 2016 4:26 am

I could find it with both, web and Play store app.

If it is shown on the web but not in the app, web site probably shows your devices as not compatible...

xabierpayet
Posts: 160
Joined: Fri Feb 24, 2012 10:34 am

Re: tablet apk and playstore

Post by xabierpayet » Wed Dec 07, 2016 4:34 am

curious, you can test it in your device? is a single scoreboard

User avatar
airsoftsoftwair
Posts: 2482
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany
Contact:

Re: tablet apk and playstore

Post by airsoftsoftwair » Wed Dec 07, 2016 11:05 pm

The problem is that the Hollywood APK Compiler supports Android 2.3. Tablet support was introduced in Android 3.0. Thus, all apps developed for 2.3 are considered "Designed for phones", although they work on tablets as well of course. But I agree that it's not nice that such apps don't show up for tablets so I think I need to update the Hollywood APK Compiler to allow you to create phone/tablet APKs. But those APKs will need at least Android 3.0 then but I think there are no people on 2.3 anyway today :)

xabierpayet
Posts: 160
Joined: Fri Feb 24, 2012 10:34 am

Re: tablet apk and playstore

Post by xabierpayet » Wed Dec 07, 2016 11:59 pm

ok, i wait for the update, some new android functions will be nice too, or add at "showkeyboard" can use (true/false) for numerical/alphabetical keyboard

zylesea
Posts: 169
Joined: Tue Feb 16, 2010 1:50 am
Location: Westfalen/Germany
Contact:

Re: tablet apk and playstore

Post by zylesea » Thu Dec 08, 2016 11:56 am

airsoftsoftwair wrote:The problem is that the Hollywood APK Compiler supports Android 2.3. Tablet support was introduced in Android 3.0. Thus, all apps developed for 2.3 are considered "Designed for phones", although they work on tablets as well of course. But I agree that it's not nice that such apps don't show up for tablets so I think I need to update the Hollywood APK Compiler to allow you to create phone/tablet APKs. But those APKs will need at least Android 3.0 then but I think there are no people on 2.3 anyway today :)
I have an 2.3 devive (an htc phone), but this is only for low end testing ;-)
I guess there are quite some 2.3 devices out there still in use. But not by "power users" - i.e. not by those ppl who install new apps. Hence, I guess we will not loose too much if you increase minimum Android version to 3.x or 4.x.

Anyway, it's quite difficult to place an app to the app store and get recognized...

User avatar
airsoftsoftwair
Posts: 2482
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany
Contact:

Re: tablet apk and playstore

Post by airsoftsoftwair » Sun Dec 11, 2016 1:04 pm

I could also make this optional, i.e. allowing the user to choose between targetting the APK for 2.3 or 4.0. Let's see.

Post Reply