gradle error with apk compiler 2.4 and android studio 3.5

Please post anything related to the Hollywood APK Compiler here
Post Reply
AlexC
Posts: 2
Joined: Sat Mar 09, 2019 2:40 am

gradle error with apk compiler 2.4 and android studio 3.5

Post by AlexC » Thu Oct 03, 2019 11:52 am

I finally got around to setup the Hollywood apk compiler v2.4 and android sdk on a PC.

I made an applet which runs fine with the Hollywood player for Android, but when I try to compile it with the apk compiler I get the following error "Failed to notify project evaluation listener" and have no idea what it means or how to fix it:
> Configure project :app
Support for CMake 3.7 and higher is a preview feature. To report a bug, see https://developer.android.com/studio/report-
bugs.html

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring project ':app'.
> Failed to notify project evaluation listener.
> org.gradle.api.tasks.compile.CompileOptions.setBootClasspath(Ljava/lang/String;)V

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with
--scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 2s

> Configure project :app
Support for CMake 3.7 and higher is a preview feature. To report a bug, see https://developer.android.com/studio/report-
bugs.html

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring project ':app'.
> Failed to notify project evaluation listener.
> org.gradle.api.tasks.compile.CompileOptions.setBootClasspath(Ljava/lang/String;)V

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with
--scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 1s
Press any key to continue . . .
The versions I have are:
APK compiler 2.4 (18.06.18)
Android studio 3.5.1 Build #AI-191.8026.42.35.5900203, built on September 25, 2019
JRE: 1.8.0_202-release-1483-b03 amd64
CMake 3.10
Gradle 5.6.2 and Gradle 5.4.1

Even though Android studio provided Gradle 5.4.1, the apk compiler was showing a requester saying that it couldn't find gradle when I clicked on "Compile APK", so I downloaded and extracted a fresh copy of gradle 5.6.2 into Android Studio\Gradle\ as that folder was empty, and finally it would start compiling but the terminal then gave me the error quoted above.

Any idea how to get past that error?

Thanks!

User avatar
airsoftsoftwair
Posts: 3159
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: gradle error with apk compiler 2.4 and android studio 3.5

Post by airsoftsoftwair » Fri Oct 04, 2019 8:24 pm

You need to use the latest version of APK compiler (3.2). The Hollywood APK Compiler always targets specific versions of Android Studio and it’s not possible to use arbitrary Android Studio versions with it because with almost every new Android Studio version there are fundamental changes under the hood so if you want to use the latest version of Android Studio you also have to use the latest version of APK Compiler....

Post Reply