Poppen on AmigaOSes

Discuss GUI programming with the MUI Royale plugin here
User avatar
tboeckel
Posts: 38
Joined: Fri Jun 06, 2014 6:17 am
Location: Germany

Re: Poppen on AmigaOSes

Post by tboeckel »

I have no idea how Hollywood or MUIRoyale works internally. All I can do is about the direct C interface to MUI. The MUIRoyale part has to be done by Andreas. And that is why I am asking here what the MUIRoyale notifications do expect and what MUI seems to fail to deliver. Simple question, isn't it?

User avatar
airsoftsoftwair
Posts: 4350
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Poppen on AmigaOSes

Post by airsoftsoftwair »

I've tested this now and I think the MUI bug is not about notifications but it seems to be that getting MUIA_Pendisplay_RGBcolor returns 0 for those 8 predefined colors above the color ring. When MUI Royale receives a MUIA_Pendisplay_Spec notification, it will get MUIA_Pendisplay_RGBcolor and return the result to the Hollywood script. When clicking on a predefined color, MUIA_Pendisplay_RGBcolor suddenly returns 0 which is clearly wrong... the return value is only correct when clicking on the color ring.

Also, there seems to be another bug as pointed out by jPV:
jPV wrote:
Tue Jul 07, 2020 7:44 am
BTW. I noticed that when you start my example script, the selected color seems to be black (0) before you even open the color ring, and when you do open it, there's some grey pen selected, which of course should have been showed initially in the small gadget too.
This should also be fixed.

User avatar
tboeckel
Posts: 38
Joined: Fri Jun 06, 2014 6:17 am
Location: Germany

Re: Poppen on AmigaOSes

Post by tboeckel »

Ok, now I finally got what is wrong. Find a fixed Pendisplay class for AmigaOS4 here. It will be contained in the next nightly build as well.

User avatar
jPV
Posts: 364
Joined: Sat Mar 26, 2016 10:44 am
Location: RNO
Contact:

Re: Poppen on AmigaOSes

Post by jPV »

Selecting pens works now.


The other issue is still there:

1) The poppen object (the button) initially shows like the black color would be selected, and if you query its RGB value at this point, you get 0 as the result. If we compare to MUI on MorphOS, on MorphOS there's an empty gadget with no color whatsover indicated, but the RGB value is also 0 there). Which is the better way, I don't know?

2) But the issue is: if you click it to open the color selection window, you see that there's actually a grey pen selected (3rd pen from the left). This is inconsistent to the black color shown in the actual object. On MorphOS there's no color/pen selected at all, which is consistent to that there is an empty button object with no color shown. So, I guess it should be like this on OS4 too, or there should be black color selected by default to be consistent with the button.

I guess this is quite minor issue in practise, but as I just happened to notice it now when testing the poppen behaviour, I'll let you know if there's will to fix it somehow :)

User avatar
tboeckel
Posts: 38
Joined: Fri Jun 06, 2014 6:17 am
Location: Germany

Re: Poppen on AmigaOSes

Post by tboeckel »

Please try the combination of Pendisplay 21.24 and Penadjust 21.24. This will add the selection button "Default color" above the normal color buttons. I think that is what you are referring to.

User avatar
jPV
Posts: 364
Joined: Sat Mar 26, 2016 10:44 am
Location: RNO
Contact:

Re: Poppen on AmigaOSes

Post by jPV »

Yeah, maybe that's a solution too, although didn't think that originally.

So, the situation was this originally if you hadn't initialized any value for the poppen object in the GUI creation, let's show it in screenshots.

Here's how it was in OS4 before that new penadjust:
Image

And here's how it is in MorphOS:
Image

Which is the best solution, I don't know, but at least that original solution in OS4 wasn't ideal.

Post Reply