IDE double Crash Bug when with certain text (s:MakeButton(I)

Forum for discussion about the Windows IDE of Hollywood
Bugala
Posts: 1040
Joined: Sun Feb 14, 2010 7:11 pm

IDE double Crash Bug when with certain text (s:MakeButton(I)

Post by Bugala »

So write to WIndows IDE following:
s:MakeButton(I

Now move your mouse pointer first on top of "n" on Button and click, next move your mousepointer on top of "I" in the end, and click, and IDE crashes.

I also noticed when I was typing:

s:MakeButton, and when I tried to type "(" it also crashed.

plouf
Posts: 264
Joined: Sun Feb 04, 2018 11:51 pm
Location: Athens,Greece

Re: IDE double Crash Bug when with certain text (s:MakeButton(I)

Post by plouf »

unable to reproduce it ,
windwos 11
Hollywood 9.1 /64bit
Christos

User avatar
airsoftsoftwair
Posts: 4984
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: IDE double Crash Bug when with certain text (s:MakeButton(I)

Post by airsoftsoftwair »

Me neither. No crash here.

Bugala
Posts: 1040
Joined: Sun Feb 14, 2010 7:11 pm

Re: IDE double Crash Bug when with certain text (s:MakeButton(I)

Post by Bugala »

oh, wonder what is causin it then. Going to make you a video about it. Windows 10 here.

Bugala
Posts: 1040
Joined: Sun Feb 14, 2010 7:11 pm

Re: IDE double Crash Bug when with certain text (s:MakeButton(I)

Post by Bugala »

here is a link to a youtube video demonstrating the problem:
https://youtu.be/SOYYpRZV2Ck

It appears the problem is more tricky than I first thought it to be.

You can see at beginning of the video me trying to trigger the bug and it doesn't.

However, after I run that other program, and receive an error from it, after that the bug happens.

However, even for that, the behavior of the bug changed after I started recording it with Camtasia. I don't know if recording somehow affected its behavior, but even after restarting the computer after the recording, the behavior stayed the same.

Before the idea was that when that bug triggered, it kept doing thing even I restarted Hollywood IDE. However, after I started the recording, it changed into becoming a one-time problem.

That after my program crashes, then the bug will trigger and crash Hollywood IDE only once. When I now restart Hollywood IDE, it doesnt trigger the bug again, until my program crashes first again.

I dont know what all kind of crashes cause this bug to become active, but the crash that happens in this program in this video is caused by this line:
If HaveItem(button.evttable, button.status) = True Then button.evttable[button.status](button.userdata)

point in this is that button.evttable doesnt exist, causing it to crash.

Idea is that I have this my_MakeButton command, where I am supposed to send this evttable, which is then saved to button.evttable.

However, idea is basically following:

Code: Select all

evttableTypedCorrectly = {stuff}
my_MakeButton(evttableTypedWrong)
and therefore evttableTypedWrong don't exist at all and it sends this non-existing evttable to button.evttable, which it tries to access later and crashes the program, which in turn causes the bug to become active.

Bugala
Posts: 1040
Joined: Sun Feb 14, 2010 7:11 pm

Re: IDE double Crash Bug when with certain text (s:MakeButton(I)

Post by Bugala »

Just took a try with a following code to simulate the crash situation:

Code: Select all

button = {}
Function sendEVTTABLE(evttable)
	button.evttable=evttable
EndFunction

sendEVTTABLE(nothing)

If HaveItem(button.evttable, button.status) = True Then button.evttable[button.status](button.userdata)
This doesn't seem to trigger the bug, so that kind of crash alone in that situation is not the cause of the bug being triggered.

I guess it is pretty impossible to track down the cause of that bug since there is so much code here and really no other clue about it than the one I just tried.

Oh yeah, just to point out, when I run that program without that empty evttable crash, it doesnt trigger the bug, so for the bug to trigger, it does regure that crash, but I guess it reguires something else too in addition, just no clue what.

Bugala
Posts: 1040
Joined: Sun Feb 14, 2010 7:11 pm

Re: IDE double Crash Bug when with certain text (s:MakeButton(I)

Post by Bugala »

I tried crashing that program other ways too, and I was able to find another alternative to triggering the problem, which is similar to the previous one:

Code: Select all

GFXbrush = GFX[GFX.status].GFX
In here I purpose did the same thing that I send to the function nonexisting Variable again, and when it tries to access it, the ".GFX" variable, it crashes again.

So it seems to do with sending nonexisting variable to a function and saving it as part of a table and then trying to access it. Just like the simulation code does.

However, the simulation code doesnt trigger the bug, so it must be in connection with something else too.

I tried crashing the program some other ways too, like trying to access nonexisting function, but that didnt trigger the bug.

User avatar
airsoftsoftwair
Posts: 4984
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: IDE double Crash Bug when with certain text (s:MakeButton(I)

Post by airsoftsoftwair »

Btw, are you on 9.1 already or are you running an older version?

Bugala
Posts: 1040
Joined: Sun Feb 14, 2010 7:11 pm

Re: IDE double Crash Bug when with certain text (s:MakeButton(I)

Post by Bugala »

9.0 still, but good point. Going to update to 9.1 next week and try if it still happens.

User avatar
airsoftsoftwair
Posts: 4984
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: IDE double Crash Bug when with certain text (s:MakeButton(I)

Post by airsoftsoftwair »

Bugala wrote:
Sun May 08, 2022 5:57 pm
9.0 still, but good point. Going to update to 9.1 next week and try if it still happens.
Yes, please do that. There have been some fixes to the IDE in 9.1 so I wouldn't be surprised if the problem is gone with 9.1.

Post Reply