MHE_0.9B

Discuss anything about the Hollywood plugins for Cubic IDE and Codebench here
ArtBlink
Posts: 435
Joined: Mon Nov 01, 2010 11:37 am
Location: Albert - France
Contact:

Re: MHE_0.9B

Post by ArtBlink » Sun Jan 17, 2016 6:55 pm

I use mui help function, normaly, it work on morphos and AOS ;-)

HelmutH
Posts: 188
Joined: Fri Feb 19, 2010 2:41 pm
Location: Oberhausen / Germany
Contact:

Re: MHE_0.9B

Post by HelmutH » Tue Jan 19, 2016 8:06 pm

ArtBlink wrote:Hello,

New Helmuth version :

I use 3 colors (only when you select command in listview not in the texteditor)

I have modified code on command list (all command = Hollywood+muiroyale+glgalore)

Is ti possible to know if Morphos version work please?

correction of german version ;-) (Thanks Helmuth)

Thanks
Hello ArtBlink
Very good, with the different colors in the script field.
With the color is only works in the script field, but not in the command line.
Here is only works the Hollywood and GL commands not the MUI commands.

Thanks for the german translation update.
greeting Helmut

ArtBlink
Posts: 435
Joined: Mon Nov 01, 2010 11:37 am
Location: Albert - France
Contact:

Re: MHE_0.9B

Post by ArtBlink » Wed Jan 20, 2016 7:08 pm

It can work with command line because i insert in the script file the pen code.

Hollywood don't understand pen code, so it is for him a syntaxe error. Sorry

ArtBlink
Posts: 435
Joined: Mon Nov 01, 2010 11:37 am
Location: Albert - France
Contact:

Re: MHE_0.9B

Post by ArtBlink » Sat Jan 23, 2016 12:44 pm

New version to test color for syntaxe

I work on tools to save your script in TXT format whitout ascii pen code

It is not very difficult, just long to make ;-)

Good test

HelmutH
Posts: 188
Joined: Fri Feb 19, 2010 2:41 pm
Location: Oberhausen / Germany
Contact:

Re: MHE_0.9B

Post by HelmutH » Sat Jan 23, 2016 10:52 pm

Unfortunately, the same situation with the color how in the previous version.
greeting Helmut

ArtBlink
Posts: 435
Joined: Mon Nov 01, 2010 11:37 am
Location: Albert - France
Contact:

Re: MHE_0.9B

Post by ArtBlink » Sun Jan 24, 2016 8:26 am

When you type in the editor :

gl.cl

Normaly, a new window open with list of gl commande like hollywood command, and when you select gl.clear for exemple, the gl command is insert in blue

It is the same thinks with muiroyale command, but muiroyal command is insert in red

It is don't work?

It is work here ;-)

Thanks for return

HelmutH
Posts: 188
Joined: Fri Feb 19, 2010 2:41 pm
Location: Oberhausen / Germany
Contact:

Re: MHE_0.9B

Post by HelmutH » Mon Jan 25, 2016 8:05 pm

Hi ArtBlink
No, that is working, but not in the line over the script field. See picture.
Image
greeting Helmut

ArtBlink
Posts: 435
Joined: Mon Nov 01, 2010 11:37 am
Location: Albert - France
Contact:

Re: MHE_0.9B

Post by ArtBlink » Fri Jan 29, 2016 7:55 pm

Ok ;-)

I just modify my script

So, i can't when i load script modify color of all command, because the traitment could be too long and you must wait too long time when you load script

I research a method, but i think it is not possible at this time

Thanks

ArtBlink
Posts: 435
Joined: Mon Nov 01, 2010 11:37 am
Location: Albert - France
Contact:

Re: MHE_0.9B

Post by ArtBlink » Sat Jan 30, 2016 1:41 pm

New version :

Executable for :

AOS4.x
Morphos
680x0+cgfx
Warpos

some command is modify by color like if, endif, wend, while, function, endfunction...

Be careful, a bug with Tab key ;-) i work on it

good test

Always helmuth.lha archive

HelmutH
Posts: 188
Joined: Fri Feb 19, 2010 2:41 pm
Location: Oberhausen / Germany
Contact:

Re: MHE_0.9B

Post by HelmutH » Sat Jan 30, 2016 4:09 pm

Good work from you :!: :)
And many thanks for the new OS3 and WOS version. 8-)
greeting Helmut

Post Reply