Running Hollywood from RAD:

Discuss any general programming issues here
Post Reply
alfkil
Posts: 4
Joined: Sun Feb 14, 2010 1:54 pm

Running Hollywood from RAD:

Post by alfkil » Sat Mar 06, 2010 12:27 pm

I'm trying to find a way to cut down memory usage for my Hollywood script, so I generated batch file that makes a RAD: drive with a startup-sequence something like this:

CD "System:"
C/ASSIGN C: C
ASSIGN DEVS: DEVS
Assign KEYMAPS: DEVS:KeyMaps
ASSIGN LIBS: LIBS
ASSIGN CLASSES: Classes
Assign T: RAM:
ASSIGN L: L
ASSIGN S: S
ASSIGN FONTS: FONTS
C:Setpatch >NIL Quiet
C:LoadMonDrvs
C:AddDataTypes REFRESH
C:IPrefs

CD "Work:code/Hollywood/BEFighters"
echo "Starting BE Fighters..." >work:test.log
BEFighters.aos4
echo "Done!" >work:test.log
RemRad force
Wait 4
C:reboot fast

Now, when booting from this RAD: disk, the above script just hangs on the line "BEFighters.aos4", which is my compiled Hollywood script. My question is: Why does it hang, and is there a way to work around it?

I have tried also just booting with no startup-sequence and manually typing the commands, but Hollywood wont start because the shell starts up in PAL screen mode...

User avatar
airsoftsoftwair
Posts: 3201
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Running Hollywood from RAD:

Post by airsoftsoftwair » Sun Mar 07, 2010 10:00 pm

I have no idea :) Try SnoopDOS and see if it says something... starting Hollywood without loading Workbench first is not supported and I don't know if it's possible at all. You can try it, but no guarantees :)

Post Reply