Raspberry Pi: Error configuring ALSA PCM output stream

Discuss any general programming issues here
Post Reply
xz79
Posts: 18
Joined: Thu Mar 14, 2013 10:12 am

Raspberry Pi: Error configuring ALSA PCM output stream

Post by xz79 » Thu Jun 04, 2015 10:17 pm

On the Raspberry Pi a hollywood program from me halts with the error message "Error configuring ALSA PCM output stream".

This happens when "PlayMusic" tries to start the background music. The sound file is in the AIFF format. The AIFF plugin is in the same directory as the hollywood program.
It was tried on a freshly installed Raspbian (the latest version from May 2015). I guess that in Raspbian ALSA is out-of-the-box properly configured already?
The hardware is a Raspberry Pi 1 B.

What could be my error?

User avatar
airsoftsoftwair
Posts: 3113
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Raspberry Pi: Error configuring ALSA PCM output stream

Post by airsoftsoftwair » Fri Jun 05, 2015 11:17 am

What is the exact PCM layout of this AIFF sound file? (bit depth, playback frequency, channels)

xz79
Posts: 18
Joined: Thu Mar 14, 2013 10:12 am

Re: Raspberry Pi: Error configuring ALSA PCM output stream

Post by xz79 » Fri Jun 05, 2015 1:21 pm

The layout ist:

Channels: Stereo
Sample rate: 44100 Hz
Bits per sample: 16

User avatar
airsoftsoftwair
Posts: 3113
Joined: Fri Feb 12, 2010 2:33 pm
Location: Germany
Contact:

Re: Raspberry Pi: Error configuring ALSA PCM output stream

Post by airsoftsoftwair » Fri Jun 05, 2015 10:55 pm

I tried it here with a 44khz, 16-bit stereo sample and it's working fine on Raspberry Pi 1 and 2.

These are my versions of Raspbian:

On the Pi 1:

Code: Select all

pi@raspberrypi ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 7.1 (wheezy)
Release:        7.1
Codename:       wheezy
On the Pi 2:

Code: Select all

pi@raspberrypi ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 7.8 (wheezy)
Release:        7.8
Codename:       wheezy
Have you tried to play the file with some other program? Maybe it's an ALSA configuration error...

xz79
Posts: 18
Joined: Thu Mar 14, 2013 10:12 am

Re: Raspberry Pi: Error configuring ALSA PCM output stream

Post by xz79 » Mon Jun 08, 2015 8:32 pm

I will check deeper on this on the weekend.
Thank you for your help so far.

Post Reply