Search found 206 matches

by amyren
Sun Apr 25, 2021 8:22 pm
Forum: RapaGUI
Topic: How to align textentries (or set the column width)?
Replies: 9
Views: 412

Re: How to align textentries (or set the column width)?

Here is the XML I was using at the time I posted the question. (have redesigned since then as a workaround) Another question I have been wondering, what do I need to do with it if I want this dialog window to be resizeable? <?xml version="1.0" encoding="iso-8859-1"?> <dialog id="dlg" title="Legg til...
by amyren
Sat Apr 24, 2021 5:56 pm
Forum: RapaGUI
Topic: Indexing sequence for textentries on Android
Replies: 4
Views: 217

Re: Indexing sequence for textentries on Android

Just take your own example Dialog, make an applet of it to use with Hollywood player. Copy the xml files to the Dialogs folder but change the edit.xml from <colgroup columns="2"> to <colgroup columns="4">
by amyren
Sat Apr 24, 2021 4:38 pm
Forum: RapaGUI
Topic: listview tooltip limitations
Replies: 3
Views: 169

Re: listview tooltip limitations

This is on windows 10, I have not tried on other platforms yet.
by amyren
Sat Apr 24, 2021 4:36 pm
Forum: RapaGUI
Topic: How to align textentries (or set the column width)?
Replies: 9
Views: 412

Re: How to align textentries (or set the column width)?

I do use colgroup for this. The dialogs example is only using one colgroup, so they would be perfectly aligned. The misalignment happens when using multiple colgroups with different number of columns. Eg first a colgroup using 4 columns, then 2 columns, followed by a colgroup with 4 columns. The two...
by amyren
Sat Apr 24, 2021 12:57 pm
Forum: RapaGUI
Topic: Createport not working with RapaGUI
Replies: 6
Views: 217

Re: Createport not working with RapaGUI

Thanks for the lesson, it led me to read a bit more about error codes:) Unfortunately it still will not work. The problem is that GetLastError() will never get that specific error code, it returns the 1010 code instead. Which is "Unable to open window" ExitOnError(False) CreatePort("TEST") code=GetL...
by amyren
Fri Apr 23, 2021 10:35 pm
Forum: RapaGUI
Topic: SystemRequest / moai.request displayed as a list
Replies: 2
Views: 102

Re: SystemRequest / moai.request displayed as a list

Thanks, that explains it.
The easiest workaround for most cases is to rephrase the text in the requestor so that it fits the standard Yes/No or OK/Cancel answers.
by amyren
Fri Apr 23, 2021 10:26 pm
Forum: RapaGUI
Topic: Createport not working with RapaGUI
Replies: 6
Views: 217

Re: Createport not working with RapaGUI

I run it on windows 10. For a working example, open the RapaGUI Dialogs.hws example and put this piece of code just before the main loop. ExitOnError(False) CreatePort("TEST") code=GetLastError() If code<>0 SystemRequest("Warning", "Program is already running", "OK",#REQICON_ERROR) EndIf ExitOnError...
by amyren
Fri Apr 23, 2021 3:36 pm
Forum: RapaGUI
Topic: SystemRequest / moai.request displayed as a list
Replies: 2
Views: 102

SystemRequest / moai.request displayed as a list

When using systemrequest() or moai.request() and the buttons are set to anything else than "OK", "Cancel", "Yes" or "No" the choices will turn up as a list instead as buttons.
Is that a known limitation with RapaGUI or a bug (I could not find it mentioned in the docs)?
by amyren
Fri Apr 23, 2021 3:31 pm
Forum: RapaGUI
Topic: Createport not working with RapaGUI
Replies: 6
Views: 217

Createport not working with RapaGUI

I tried using CreatePort() in my program for the purpose of detecting if the program was ran twice.
But it fail to create a port at all, and triggers the error.
The errorname is "Unable to open Window"

Is there another option for this purpose when using RapaGUI?
by amyren
Tue Apr 20, 2021 9:21 pm
Forum: RapaGUI
Topic: listview tooltip limitations
Replies: 3
Views: 169

listview tooltip limitations

Using tooltip in a listview does work on its own, but can not be used in certain combinations this will show the tooltip <listview id="lv" tooltip="Tooltip test" notify="active"> <column title="Name"/> </listview> With editable set for one of the columns, the tooltip is missing <listview id="lv" too...