Search found 296 matches

by jPV
Sat Sep 03, 2016 8:56 am
Forum: Showcase
Topic: RNOInfoScreen
Replies: 13
Views: 9608

RNOInfoScreen

My first Hollywood coding project. I had an idea for this and learned Hollywood by trying if I can make all the features I had in my mind, and I pretty much found everything I need in Hollywood :) Coded with CubicIDE on MorphOS, but compiled and added some support also for OS4, 68k, and WarpOS (not ...
by jPV
Sat Jun 18, 2016 12:42 pm
Forum: Showcase
Topic: Finnish Amiga Users Group's info screen
Replies: 1
Views: 2153

Finnish Amiga Users Group's info screen

Couple days of intensive learning with Hollywood Designer resulted an info screen display at Finnish Amiga Users Group's stand at Vectorama 2016 LAN party. The party had about 2000 visitors and our stand was crowded most of the time too. I'm not sharing the script now due to possibility of copyright...
by jPV
Thu May 26, 2016 9:04 am
Forum: General programming
Topic: playing mp3 via datatypes doesn't work under MOS
Replies: 12
Views: 7807

Re: playing mp3 via datatypes doesn't work under MOS

And I did use the code in the first post for these tests, with OpenMusic(). Although it was said that it shouldn't use datatypes, but there seemed to be datatypes references in the Snoopium log anyway. The first time I myself started to notice that all mp3 files won't play was with the HollyAMP exam...
by jPV
Wed May 25, 2016 6:18 pm
Forum: General programming
Topic: playing mp3 via datatypes doesn't work under MOS
Replies: 12
Views: 7807

Re: playing mp3 via datatypes doesn't work under MOS

Well.. I removed Reggae and tried with Multiview, it's using datatypes then, and Multiview played now the same songs as Hollywood did under Windows. Interestingly that one same song didn't play, but others did.
by jPV
Wed May 25, 2016 5:29 pm
Forum: General programming
Topic: playing mp3 via datatypes doesn't work under MOS
Replies: 12
Views: 7807

Re: playing mp3 via datatypes doesn't work under MOS

I also noticed that quite big percentage of mp3 files won't work with Hollywood on MorphOS. Some files complain "Sound file "a.mp3" is in an unknown/unsupported format!", some just don't play (nothing heard, or just very short "blip"). And they all do play fine with Multiview, Ambient's internal pla...
by jPV
Wed May 18, 2016 6:50 pm
Forum: Hollywood bugs
Topic: Problem with Menu in HW 6.1
Replies: 11
Views: 6139

Re: Problem with Menu in HW 6.1

The only solution to this that I see is to use a new flag for @DISPLAY that allows you to set whether you want to have RMB events at the expense of being unable to listen to the RMB or if you don't want to have RMB events in order to allow the menu bar to be opened by right clicking over the displa...
by jPV
Mon May 16, 2016 5:53 pm
Forum: Hollywood bugs
Topic: Problem with Menu in HW 6.1
Replies: 11
Views: 6139

Re: Problem with Menu in HW 6.1

I noticed this on MorphOS too. You can have system settings configured so that menus would appear under mouse pointer instead of just from the screen title bar, but that doesn't work with Hollywood programs and it makes them behave in a non-standard way. I think the best would be that if you don't t...
by jPV
Thu Apr 28, 2016 7:19 pm
Forum: Hollywood bugs
Topic: Problems with Run()
Replies: 4
Views: 3154

Re: Problems with Run()

Yes, it seems to hit on MorphOS too (log). The wanted program starts, but hit in the log, so it doesn't behave correctly.
by jPV
Tue Apr 26, 2016 6:39 pm
Forum: Hollywood bugs
Topic: DisableBlanker
Replies: 5
Views: 3488

Re: DisableBlanker

And can DisableBlanker be configured later when the display is already open? Manual doesn't seem to have it on SetDisplayAttributes() at least...