Search found 297 matches

by jPV
Mon Jul 31, 2017 3:49 pm
Forum: MUI Royale
Topic: Listview and brush
Replies: 8
Views: 4980

Re: Listview and brush

The brushes are cached as explained recently here: http://forums.hollywood-mal.com/viewtopic.php?f=21&t=1669 You have to use different ID for different listview brushes... I also hitted to this problem with my program, which has thumbnail images on each listview entry, and the entires are changing d...
by jPV
Sun Jul 30, 2017 7:03 pm
Forum: MUI Royale
Topic: EventHandler
Replies: 2
Views: 1632

Re: EventHandler

Yeah, as far as I can see, the first version would never go to the Default case. MUI events you get from user input are handled before it, and nothing triggers any MUI event automatically.
by jPV
Thu Jul 27, 2017 12:40 pm
Forum: General programming
Topic: Some JPEG pictures don't work...
Replies: 16
Views: 7142

Re: Some JPEG pictures don't work...

Sorry, somehow missed the second page of the thread. But I now also tried the pics and code under Hollywood7/Win10/64bit and it worked fine there too. I'll let Andreas continue from here :)
by jPV
Thu Jul 27, 2017 12:21 pm
Forum: General programming
Topic: Some JPEG pictures don't work...
Replies: 16
Views: 7142

Re: Some JPEG pictures don't work...

Anyway maybe the problem is that all the pics that don't work are photos taken by mobile phones - either with my Sony XPERIA E104 or with another phones of my friends so maybe they save the images in some strange format?? I don't think they're in that strange format, because they did show up just f...
by jPV
Thu Jul 27, 2017 10:36 am
Forum: General programming
Topic: Some JPEG pictures don't work...
Replies: 16
Views: 7142

Re: Some JPEG pictures don't work...

Yeah, I tried with both inbuilt and native options, and both worked.
by jPV
Wed Jul 26, 2017 8:32 pm
Forum: General programming
Topic: Some JPEG pictures don't work...
Replies: 16
Views: 7142

Re: Some JPEG pictures don't work...

The test images seem to work fine with Hollywood 7 under MorphOS here. I tested with your code snippet, and no problems, images are loaded and also displayed correctly. Images also seem to be traditional JPEGs, not JPEG 2000 images. Maybe I'll test more tomorrow or if I bother to revert to Hollywood...
by jPV
Wed Jul 26, 2017 2:00 pm
Forum: General programming
Topic: Some JPEG pictures don't work...
Replies: 16
Views: 7142

Re: Some JPEG pictures don't work...

I have never run into that kind of issue myself... could you share one example picture which doesn't work?
by jPV
Fri Jun 30, 2017 8:46 am
Forum: MUI Royale
Topic: Listview keyboard on MorphOS
Replies: 5
Views: 2976

Re: Listview keyboard on MorphOS

Hmm.. true. The listview in the Listviews window doesn't work, but then the listview in the Strings window does work. It looks like that you need to activate the cyclechain and then keyboard controls do work. This put to listview definition in XML seems to do the trick and then the Listviews demo wo...
by jPV
Thu Jun 29, 2017 9:06 am
Forum: MUI Royale
Topic: Listview keyboard on MorphOS
Replies: 5
Views: 2976

Re: Listview keyboard on MorphOS

Have you tried to activate the listview (clicking/tab) before using the cursor keys?
by jPV
Sat Jun 17, 2017 1:19 pm
Forum: Showcase
Topic: Results program/screen for game competitions
Replies: 1
Views: 1894

Results program/screen for game competitions

No public release (at least yet), but I made a two part program for games competitions at a LAN party we attended last weekend. The first part of the program is a MUI GUI where you can enter player names, put in their scores, sort the competitors randomly or by the score, and upload the lists to a r...