Search found 358 matches

by jPV
Wed Jul 08, 2020 8:06 pm
Forum: MUI Royale
Topic: Poppen on AmigaOSes
Replies: 15
Views: 308

Re: Poppen on AmigaOSes

Yeah, maybe that's a solution too, although didn't think that originally. So, the situation was this originally if you hadn't initialized any value for the poppen object in the GUI creation, let's show it in screenshots. Here's how it was in OS4 before that new penadjust: http://jpv.wmhost.com/testi...
by jPV
Tue Jul 07, 2020 6:13 pm
Forum: MUI Royale
Topic: Poppen on AmigaOSes
Replies: 15
Views: 308

Re: Poppen on AmigaOSes

Selecting pens works now. The other issue is still there: 1) The poppen object (the button) initially shows like the black color would be selected, and if you query its RGB value at this point, you get 0 as the result. If we compare to MUI on MorphOS, on MorphOS there's an empty gadget with no color...
by jPV
Tue Jul 07, 2020 7:44 am
Forum: MUI Royale
Topic: Poppen on AmigaOSes
Replies: 15
Views: 308

Re: Poppen on AmigaOSes

That Class2 demo works fine, it seems to give color values. And on Hollywood program it's not about notifications only, I just made it in the event function to be tested easily realtime with different selections. It also fails when you do ConsolePrint(mui.Get("color", "RGB")) anywhere. BTW. I notice...
by jPV
Mon Jul 06, 2020 8:03 pm
Forum: RapaGUI
Topic: Converting MUI to RAPA
Replies: 3
Views: 95

Re: Converting MUI to RAPA

Some (most?) plugins load automatically at startup if you have them in the directories Hollywood looks for plugins. In this case you don't need the @REQUIRE line at all. So, in your case it probably loads both plugins at startup and that's why MUI Royale still works. If you remove muiroyale.hwp file...
by jPV
Mon Jul 06, 2020 5:44 pm
Forum: MUI Royale
Topic: Poppen on AmigaOSes
Replies: 15
Views: 308

Re: Poppen on AmigaOSes

Sorry for not testing this earlier... unfortunately it still doesn't seem to work here.

Here's when I've clicked the predefined pens, it just gives 0 no matter which of them I select: pic 1

And it gives correct color values if I select from that color ring thing: pic 2
by jPV
Mon Jun 29, 2020 8:12 pm
Forum: Off topic
Topic: Can't login into the forum with OWB anymore
Replies: 4
Views: 352

Re: Can't login into the forum with OWB anymore

Yes, works now, thanks!
by jPV
Sat Jun 27, 2020 3:21 pm
Forum: General programming
Topic: Table name as variable
Replies: 3
Views: 192

Re: Table name as variable

How about putting your tables inside one main table (better use lowercase names to avoid troubles)? tables={ table1={1,2,3}, table2={"a","b","c"}, table3={"d1","d2","d3"} } Table_I_wan_to_use$="table2" DebugPrint(tables[Table_I_wan_to_use$][0]) Function Dosomethngwithtable(tablename$) ;now I can't f...
by jPV
Sat Jun 27, 2020 2:03 pm
Forum: Off topic
Topic: Can't login into the forum with OWB anymore
Replies: 4
Views: 352

Re: Can't login into the forum with OWB anymore

I think it's mainly because the cookies popup has changed and doesn't appear/work on OWB anymore. You can see that Register/Login links don't appear on mainstream browsers either before accepting cookies, and you just can't accept them anymore with OWB. Here's a screenshot showing how they don't app...
by jPV
Thu Jun 25, 2020 7:40 am
Forum: Announcements
Topic: Autolinks for Hollywood forums
Replies: 6
Views: 227

Re: Autolinks for Hollywood forums

*air-guitaring*
by jPV
Thu Jun 18, 2020 5:25 pm
Forum: MUI Royale
Topic: Zune Popdrawer doesn't receive notify on "Acknowledge"
Replies: 6
Views: 5101

Re: Zune Popdrawer doesn't receive notify on "Acknowledge"

I came up with some other bugs that are new to me at least. - If you try to use the Acknowledge notification with normal string gadgets, it apparently receives something because it totally crashes when getting them. - ListTree notifications seem to crash there too. At least Active and DoubleClick, a...