Search found 54 matches

by TheMartian
Wed May 31, 2017 2:24 pm
Forum: Newbie questions
Topic: need a random value from table
Replies: 6
Views: 2212

Re: need a random value from table

Hi The procedure I suggest will work provided the value you are interested in is the content (which might be a number or a string) and not its index in an table. As I understand your task, you have a list of values and wish to grab a random item in the list for some purpose, then reduce the list by ...
by TheMartian
Tue May 30, 2017 2:54 pm
Forum: Newbie questions
Topic: need a random value from table
Replies: 6
Views: 2212

Re: need a random value from table

Hi I think you may be able to simplify the process even further without a help table by using RemoveItem() like this... mytbl = {10, 5, 20} Function GetRndValue() Local response rand=Rnd(TableItems(mytbl)) response=mytbl[rand] RemoveItem(mytbl,rand) Return(response) EndFunction Now each call to the ...
by TheMartian
Wed Apr 12, 2017 10:18 pm
Forum: Announcements
Topic: Hollywood 7: Eternity out now!
Replies: 42
Views: 19689

Re: Hollywood 7: Eternity out now!

Hi Turns out there is this little thing called a Warp3D_SI driver required for my gfx card. Doh! I bought it for my previous SSD setup, installed it, and forgot to write a note about it in my installation notes then. Reinstalling it on the new setup solved the problem and GLGalore works for me now. ...
by TheMartian
Tue Apr 11, 2017 1:38 pm
Forum: Announcements
Topic: Hollywood 7: Eternity out now!
Replies: 42
Views: 19689

Re: Hollywood 7: Eternity out now!

Hi I downloaded minigl.lha and unpacked it and ran the example icalled 'Picksquare' in the demo folder. As you anticipated, it failed with the message: Could not create an OpenGL window/context I looked at the minigl.library and mglut.library in the Libs directory. The versions in the regular instal...
by TheMartian
Mon Apr 10, 2017 7:37 pm
Forum: Announcements
Topic: Hollywood 7: Eternity out now!
Replies: 42
Views: 19689

Re: Hollywood 7: Eternity out now!

Hi My problem seemed to be solved... and then again....DOH! I did a complete blank reinstall on a totally clean X1000 machine of Amiga OS 41.FE. All partitions newly created etc. 1) Install Amiga OS 4.1 FE 2) Update with RadeonHD 2.7 3) Install HW7 from CD. 4) Download GLGalore 1.0 and install. Holl...
by TheMartian
Tue Apr 04, 2017 5:17 pm
Forum: Announcements
Topic: Hollywood 7: Eternity out now!
Replies: 42
Views: 19689

Re: Hollywood 7: Eternity out now!

Hi My problem with running GL Galore on an X1000 with HW7 seems to be solved. After switching to a newer graphics card (RadeonHD R7 250X 1Gb) it worked. The old Radeon HD 6570 seems to have issues with the new drivers though. Well... back to the keyboard to play around some more with HW7 ;) regards ...
by TheMartian
Fri Mar 31, 2017 10:11 pm
Forum: Announcements
Topic: Hollywood 7: Eternity out now!
Replies: 42
Views: 19689

Re: Hollywood 7: Eternity out now!

Hi It could well be, that the latest graphics driver and the recent FE update has something to do with my problem, as you suggest. I deleted the existing installation of Hollywood completely and reinstalled it, and I continue to have the error described on my X1000. I also dug up my old SAMep440ep a...
by TheMartian
Thu Mar 30, 2017 1:38 pm
Forum: Announcements
Topic: Hollywood 7: Eternity out now!
Replies: 42
Views: 19689

Re: Hollywood 7: Eternity out now!

Hi I have just installed HW7 on my X1000. I can see that there are new versions of some plugins and extras like the APK compiler etc. What concerns me is that all programs with GL Galore fails to work. There seems to be an issue with opening screens. If I run a program like 'Simple' from the GUI in ...
by TheMartian
Wed Sep 07, 2016 9:16 pm
Forum: General programming
Topic: Speed improvement guidelines
Replies: 6
Views: 2829

Re: Speed improvement guidelines

Hi A couple of years ago I wrote an article on the subject (Speeding up Hollywood programs). I don't have the link to the website, where it was published anymore. But it provides some ideas for simple things to do that can pay off nicely. I think I found the draft, and it is included here below... -...
by TheMartian
Sun Mar 27, 2016 11:21 pm
Forum: Hollywood bugs
Topic: Protect bit setting for Amiga Plugins
Replies: 1
Views: 1085

Protect bit setting for Amiga Plugins

Hi I am not sure if this is a bug at all, or there may be some reason for it, and besides I dont' thing it makes much difference .... Anyway, here we go...after having updated to HW 6.1 I loaded all the current 21 plugins for the Amiga and installed them using the provided installer program. When I ...