Search found 422 matches

by jPV
Fri Oct 15, 2021 2:56 pm
Forum: General plugin questions
Topic: Plananarama and amiga without graphic card
Replies: 16
Views: 5551

Re: Plananarama and amiga without graphic card

Check the requirements section in my readme here: http://aminet.net/package/gfx/show/RNOPDF_ECS-AGA That was the combo that worked on my A1200/KS3.1 with B1230-IV (no FPU). And about the "Error allocating bitmap!" error. Have you tried to use smaller display for your HW script? Default dimensions ar...
by jPV
Fri Oct 15, 2021 8:50 am
Forum: Hollywood bugs
Topic: Multi CreateBrush() with NIL no release brush
Replies: 5
Views: 146

Re: Multi CreateBrush() with NIL no release brush

If you have the same ID, then you don't need to do FreeBrush(). It's just that you don't get the same ID ever if you're using NIL to create a brush. Just use static IDs if you need to use the same ID, reserve certain IDs for certain uses and you're fine. If you do "CreateBrush(15,200,200,#BLUE)", it...
by jPV
Thu Oct 14, 2021 7:33 pm
Forum: Hollywood bugs
Topic: Multi CreateBrush() with NIL no release brush
Replies: 5
Views: 146

Re: Multi CreateBrush() with NIL no release brush

If i use CreateBrush(ID) With FOR => Good Work 1 brush maked FOR local i=1 TO 50 DO CreateBrush(1,200,200,#BLUE) This will always create a brush with ID 1, so it replaces (and frees) the previous brush which had the same ID (1). Only one brush stays in memory. If i use CreateBrush(NIL) With FOR => ...
by jPV
Thu Oct 14, 2021 7:19 pm
Forum: Showcase
Topic: Pixy - Pixel editor new generation
Replies: 11
Views: 736

Re: Pixy - Pixel editor new generation

@JPV I have to redraw each time the mouse is moved because it has a drawing brush in the image ... But even when it's idle and mouse doesn't move? Or at least don't redraw anything when the window isn't active... Maybe some partial refresh would also help.. not redrawing the whole image, but just t...
by jPV
Tue Oct 12, 2021 6:27 pm
Forum: Showcase
Topic: Pixy - Pixel editor new generation
Replies: 11
Views: 736

Re: Pixy - Pixel editor new generation

I upload on OS4depot My project Pixy Alpha version I downloaded the program from MorphOS Storage now and had a quick test. One thing I noticed immediately is that the program makes constant CPU load right after start even if I don't do anything. CPU usage is about 40% for Pixy on my Mac mini, so it...
by jPV
Sun Oct 03, 2021 5:21 pm
Forum: General plugin questions
Topic: Format recognizing with the avcodec plugin
Replies: 1
Views: 146

Format recognizing with the avcodec plugin

I found a small format detection issue with the avcodec plugin. It recognizes a protracker module as "MPEG audio layer 2/3" and fails to play it. Is there something that could be fixed or is this stuff hidden deep in the FFmpeg? Most mods seem to be recognized just fine, but found the issue with thi...
by jPV
Sat Oct 02, 2021 10:14 pm
Forum: MUI Royale
Topic: Weird encoding issue
Replies: 6
Views: 726

Re: Weird encoding issue

I think this might have been fixed already by this fix, which was also reported by you: - Fix: Plugin is now de-initialized correctly in the rare case that it is loaded several times from different locations I can't seem to find the corresponding thread, though. Did you report this via email or PM?...
by jPV
Mon Sep 27, 2021 4:53 pm
Forum: MUI Royale
Topic: Weird encoding issue
Replies: 6
Views: 726

Re: Weird encoding issue

Hmm.. I don't remember where I'd reported it.. didn't find it quickly either :) But more about plugins and encoding... I was reported that one of my previous programs crashes nowadays, and I hunted it down that it happens if you have the new RapaGUI 2.0 plugin installed to libs:hollywood/ and the pr...
by jPV
Thu Sep 16, 2021 6:17 pm
Forum: MUI Royale
Topic: Weird encoding issue
Replies: 6
Views: 726

Re: Weird encoding issue

Nope...
by jPV
Wed Sep 15, 2021 4:38 pm
Forum: Polybios
Topic: Background color with GetBrush
Replies: 1
Views: 497

Background color with GetBrush

According the pdf.GetBrush documentation, if you don't set the page background transparent, it should be white. This doesn't seem to be the case with all PDFs.. with some files you get black background and then texts aren't readable etc (black on black). Setting bg to transparent seems to work and y...