Search found 426 matches

by jPV
Tue Oct 26, 2021 3:29 pm
Forum: Hollywood bugs
Topic: Precision issue when saving integers in tables to JSON
Replies: 0
Views: 25

Precision issue when saving integers in tables to JSON

When I save tables with integer values as JSON with WriteTable() or SavePrefs(), some of the integer values are written as floats like 11.99999999999999 in the file. After reading these back as Hollywood tables, the values seem to be like integers if you print them, but if you try to use them as tab...
by jPV
Sat Oct 23, 2021 10:40 am
Forum: Hollywood bugs
Topic: CreateRexxPort issue
Replies: 3
Views: 123

Re: CreateRexxPort issue

I remember seeing it couple years ago with some other program, but forgot to investigate it better then and forgot which program it was then. And it didn't seem to happen since then until now again... luckily it became clearly reproduceable now and we got it fixed :)
by jPV
Thu Oct 21, 2021 5:28 pm
Forum: Hollywood bugs
Topic: CreateRexxPort issue
Replies: 3
Views: 123

CreateRexxPort issue

I got an issue where my program's ARexx port name was changing to garbled strings. It was initially what I set it, but then during the usage port seemed to vanish (didn't work anymore), but with a closer look it was still there, but its name was trashed. Sometimes the name seemed to be some totally ...
by jPV
Wed Oct 20, 2021 8:14 am
Forum: Hollywood bugs
Topic: Multi CreateBrush() with NIL no release brush
Replies: 6
Views: 265

Re: Multi CreateBrush() with NIL no release brush

Pixy uses a lot of brushes and the project also uses a lot of brushes so using static IDs would be unmanageable Yeah, then you have to catch all IDs into variables and free them manually when you replace them to avoid them being "leaked" into memory. In your original example you only "catched" one ...
by jPV
Fri Oct 15, 2021 2:56 pm
Forum: General plugin questions
Topic: Plananarama and amiga without graphic card
Replies: 34
Views: 6039

Re: Plananarama and amiga without graphic card

Check the requirements section in my readme here: http://aminet.net/package/gfx/show/RNOPDF_ECS-AGA That was the combo that worked on my A1200/KS3.1 with B1230-IV (no FPU). And about the "Error allocating bitmap!" error. Have you tried to use smaller display for your HW script? Default dimensions ar...
by jPV
Fri Oct 15, 2021 8:50 am
Forum: Hollywood bugs
Topic: Multi CreateBrush() with NIL no release brush
Replies: 6
Views: 265

Re: Multi CreateBrush() with NIL no release brush

If you have the same ID, then you don't need to do FreeBrush(). It's just that you don't get the same ID ever if you're using NIL to create a brush. Just use static IDs if you need to use the same ID, reserve certain IDs for certain uses and you're fine. If you do "CreateBrush(15,200,200,#BLUE)", it...
by jPV
Thu Oct 14, 2021 7:33 pm
Forum: Hollywood bugs
Topic: Multi CreateBrush() with NIL no release brush
Replies: 6
Views: 265

Re: Multi CreateBrush() with NIL no release brush

If i use CreateBrush(ID) With FOR => Good Work 1 brush maked FOR local i=1 TO 50 DO CreateBrush(1,200,200,#BLUE) This will always create a brush with ID 1, so it replaces (and frees) the previous brush which had the same ID (1). Only one brush stays in memory. If i use CreateBrush(NIL) With FOR => ...
by jPV
Thu Oct 14, 2021 7:19 pm
Forum: Showcase
Topic: Pixy - Pixel editor new generation
Replies: 11
Views: 981

Re: Pixy - Pixel editor new generation

@JPV I have to redraw each time the mouse is moved because it has a drawing brush in the image ... But even when it's idle and mouse doesn't move? Or at least don't redraw anything when the window isn't active... Maybe some partial refresh would also help.. not redrawing the whole image, but just t...
by jPV
Tue Oct 12, 2021 6:27 pm
Forum: Showcase
Topic: Pixy - Pixel editor new generation
Replies: 11
Views: 981

Re: Pixy - Pixel editor new generation

I upload on OS4depot My project Pixy Alpha version I downloaded the program from MorphOS Storage now and had a quick test. One thing I noticed immediately is that the program makes constant CPU load right after start even if I don't do anything. CPU usage is about 40% for Pixy on my Mac mini, so it...
by jPV
Sun Oct 03, 2021 5:21 pm
Forum: General plugin questions
Topic: Format recognizing with the avcodec plugin
Replies: 1
Views: 197

Format recognizing with the avcodec plugin

I found a small format detection issue with the avcodec plugin. It recognizes a protracker module as "MPEG audio layer 2/3" and fails to play it. Is there something that could be fixed or is this stuff hidden deep in the FFmpeg? Most mods seem to be recognized just fine, but found the issue with thi...