System freeze when adding sounds

Report any Designer bugs here

System freeze when adding sounds

Postby amigaoneproductions » Fri Feb 26, 2010 9:15 pm

I am using Designer 2.1 on an Amiga SAM440EP running OS4.1 Update 1

Whenever I try to add a sound event, as soon as I click OK after selecting a sound file, the select file requester closes and the system freezes, no mouse movement, caps lock freezes, the only way out is the reset button on the case.

I have tried adding different sound types, or changing a sound in an existing project, but the result is the same.

Any ideas ?


UPDATE:

If I manually enter the path to the sound file, and not click to bring up the file requester, it works fine. (so it's not a problem reading the sounds)
Adding other objects with a file requester, i.e. a brush object works fine, so the problem does not seem to be with the file requester either
amigaoneproductions
 
Posts: 32
Joined: Mon Feb 15, 2010 5:14 pm
Location: Nottinghamshire, UK

Re: System freeze when adding sounds

Postby airsoftsoftwair » Sun Feb 28, 2010 12:42 am

I actually got the same report from another user via email today. It could be related to OS 4.1 Update 1 which I currently don't have installed here. I'll try it myself as soon as I update to OS 4.1.1.
User avatar
airsoftsoftwair
 
Posts: 2089
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany

Re: System freeze when adding sounds

Postby amigaoneproductions » Sun Feb 28, 2010 7:58 pm

Thanks,

When I was installing Hollywood, I was careful not to overwrite any libs that were already newer than the one in the archive, so is it possible there is a version conflict with the MUI libs ?

Just a thought :-)
amigaoneproductions
 
Posts: 32
Joined: Mon Feb 15, 2010 5:14 pm
Location: Nottinghamshire, UK

Re: System freeze when adding sounds

Postby airsoftsoftwair » Mon Mar 01, 2010 11:08 pm

Ok, I've checked it and this really seems to be a bug in OS4. OS4 always crashes when trying to open a 1x1 pixel window, i.e. try the following:

Code: Select all
@DISPLAY {Width = 1, Height = 1}
WaitLeftMouse
End


This always crashes here. I thought that this would have been fixed in Update 1 because Tuxedo told me that he no longer got crashes with Update 1 but if Designer crashes after selecting a sound file, then the bug is definitely still in OS4. I haven't found time to install Update 1 here but you can check it for yourself. Just try the code above on Update 1. If it crashes, then the bug is still there :)

You might wonder what this has to do with the sound event in Designer. The answer is this: Whenever you select a sound file, Designer starts Hollywood and lets Hollywood check the sound format (Designer doesn't contain any sound code). When Designer starts Hollywood, it sets the display size to 1x1 so that the user doesn't notice that Hollywood has just been started :)
User avatar
airsoftsoftwair
 
Posts: 2089
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany

Re: System freeze when adding sounds

Postby amigaoneproductions » Mon Mar 01, 2010 11:12 pm

Thanks, I'll check it out tommorrow when I'm in front of the Amiga again. I'll let you know as soon as I've tested it.

Paul
amigaoneproductions
 
Posts: 32
Joined: Mon Feb 15, 2010 5:14 pm
Location: Nottinghamshire, UK

Re: System freeze when adding sounds

Postby Mufa » Tue Mar 02, 2010 3:59 pm

Andreas wrote:Ok, I've checked it and this really seems to be a bug in OS4. OS4 always crashes when trying to open a 1x1 pixel window, i.e. try the following:

Code: Select all
@DISPLAY {Width = 1, Height = 1}
WaitLeftMouse
End



You're right. This code = my system crash.
Mufa
 
Posts: 6
Joined: Tue Mar 02, 2010 3:49 pm

Re: System freeze when adding sounds

Postby amigaoneproductions » Tue Mar 02, 2010 5:01 pm

Confirmed here as well, if you save the above code as a text file, then execute it with "hollywood foo.hws" then the system freezes.
amigaoneproductions
 
Posts: 32
Joined: Mon Feb 15, 2010 5:14 pm
Location: Nottinghamshire, UK

Re: System freeze when adding sounds

Postby amigaoneproductions » Tue Mar 02, 2010 6:56 pm

I think this also confirms that andreas is correct :
Image

If the problem is in OS4, and we don't know when or if it will be fixed, would it not be sensible to have hollywood workaround the problem by opening a 2 x 2 screen instead, if it works, what's a pixel between friends ;)
amigaoneproductions
 
Posts: 32
Joined: Mon Feb 15, 2010 5:14 pm
Location: Nottinghamshire, UK

Re: System freeze when adding sounds

Postby airsoftsoftwair » Sun Mar 07, 2010 11:01 pm

I've reported the bug to the OS4 devs and it should be fixed in the next update.
User avatar
airsoftsoftwair
 
Posts: 2089
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany

Re: System freeze when adding sounds

Postby amigaoneproductions » Sun May 02, 2010 6:41 pm

Just a note to say that the bug still exists using the latest update (OS 4.1 Update 2) so it's not fixed yet.
amigaoneproductions
 
Posts: 32
Joined: Mon Feb 15, 2010 5:14 pm
Location: Nottinghamshire, UK

Next

Return to Designer bugs

Who is online

Users browsing this forum: No registered users and 1 guest