Page 1 of 1

Desktop=True issue on Windows

Posted: Fri Feb 09, 2018 7:09 pm
by jPV
You probably missed this bug suspicion in a big thread here, so I'll lift it here.

It seems that the Desktop=True option for the display makes the Hollywood window to stay front all the time on Windows machines (it doesn't happen for example on MorphOS).

If you run for example this:

Code: Select all

@DISPLAY 1, {Desktop = True}
Print("bla")
WaitLeftMouse()
...you can't bring any other window to front while it's running.

Re: Desktop=True issue on Windows

Posted: Fri Feb 09, 2018 10:07 pm
by airsoftsoftwair
Right, but how do you bring a window to the top on AmigaOS/MorphOS if the front window has filled the entire screen? Is there a keyboard shortcut or something like this? On Windows you have ALT-TAB for this but I don't know of any Amiga equivalent.

Re: Desktop=True issue on Windows

Posted: Fri Feb 09, 2018 11:19 pm
by jPV
The original issue was that you can't bring second Hollywood display in front of Desktop=True display by your code. On MorphOS you can, but on Windows you can't.

I then noticed that it is more general issue and you can't bring any window to front on Windows by alt-tab or any other means.

And on AmigaOS you have commodities to bring windows to front by shortcuts, and on MorphOS you have such functionality built-in in IControl->Hotkeys. I for example have double middle mouse button to send a window to back (and can do that for my example Hollywood window) and also have amiga-tab configured to activate next windows which brings them to front (of the mentioned Hollywood display too).

Re: Desktop=True issue on Windows

Posted: Sat Feb 10, 2018 10:13 pm
by airsoftsoftwair

Code: Select all

- Fix: When setting the "Desktop" tag to TRUE in @DISPLAY, Hollywood only enforced always on top
  behaviour on Windows systems

Re: Desktop=True issue on Windows... and now on MorphOS

Posted: Tue Feb 13, 2018 5:01 pm
by jPV
This became a problem under MorphOS with 7.1 now :( A Desktop=True window will stick as "allways on top" window on MorphOS, just the same way it did on Windows.

Setting AlwaysOnTop=False doesn't help either.

Re: Desktop=True issue on Windows

Posted: Tue Feb 13, 2018 6:41 pm
by airsoftsoftwair
From my point of view forcing desktop displays on top of all other windows is the most reasonable behaviour. The Windows version already did that before 7.1 and now all other platforms follow suit. If you don't want that, you could always use GrabDesktop() and create a desktop display with custom behaviour...