Pageview title bug?

Discuss GUI programming with the RapaGUI plugin here

Pageview title bug?

Postby ilbarbax » Sun Dec 11, 2016 10:14 am

I was trying to replce the pageview title, as it should be possible per the group.title guide, as follow:

In the xml file
<pageview>

<hgroup ID="Petrol_Data" title="Data" icon="100">



and then in the code

moai.Set("Petrol_Data", "title", Cat_string$[34])

I get the error

Attribute title not recognized for this class

Is this a bug?
ilbarbax
 
Posts: 77
Joined: Thu Apr 01, 2010 6:41 pm

Re: Pageview title bug?

Postby airsoftsoftwair » Sun Dec 11, 2016 1:01 pm

No, it isn't a bug. If you read the documentation of Group.Title you can see that it has an applicability of "I", meaning that the title currently cannot be changed at runtime.
User avatar
airsoftsoftwair
 
Posts: 2025
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany

Re: Pageview title bug?

Postby airsoftsoftwair » Tue Mar 28, 2017 9:03 pm

Code: Select all
- New: Group.Title and Group.Icon now have an applicability of ISG instead of just I; this
  allows you to change the title and icon of individual pages at runtime; to remove the
  icon from a page set Group.Icon to -1; note that on AmigaOS for all Pageview.Modes except
  "List" this feature requires at least MUI 4
User avatar
airsoftsoftwair
 
Posts: 2025
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany

Re: Pageview title bug?

Postby ilbarbax » Mon Apr 03, 2017 1:33 pm

great!
ilbarbax
 
Posts: 77
Joined: Thu Apr 01, 2010 6:41 pm


Return to RapaGUI

Who is online

Users browsing this forum: No registered users and 1 guest

cron