Simple Test Crashing on Windows

Discuss GUI programming with the RapaGUI plugin here

Simple Test Crashing on Windows

Postby PEB » Sat Jul 16, 2016 9:13 pm

The following code works fine on my Amiga, but crashes when I try running in on Windows.

Code: Select all
AppStr$=[[<?xml version="1.0" encoding="iso-8859-1"?>
<application id="app">
   <window id="win" title="Test">
      <vgroup>
            <button>Test Button One</button>
            <button>Test Button Two</button>
      </vgroup>
   </window>
</application>]]

moai.CreateApp(AppStr$)


Any ideas?
PEB
 
Posts: 142
Joined: Sun Feb 21, 2010 2:28 am

Re: Simple Test Crashing on Windows

Postby msu » Sat Jul 16, 2016 10:13 pm

Hallo PEB

This code works (windows7) :

Code: Select all
@VERSION 6,1
@REQUIRE "RapaGUI"


AppStr$=[[<?xml version="1.0" encoding="iso-8859-1"?>
<application id="app">
   <window id="win" title="Test">
      <vgroup>
            <button>Test Button One</button>
            <button>Test Button Two</button>
      </vgroup>
   </window>
</application>]]

moai.CreateApp(AppStr$)

Repeat
   WaitEvent
Forever
msu
 
Posts: 16
Joined: Mon Jun 13, 2016 11:36 am
Location: Sinzig/Germany

Re: Simple Test Crashing on Windows

Postby PEB » Sun Jul 17, 2016 12:47 am

You're right! In order not to crash, this is needed:
@REQUIRE "RapaGUI"


Thanks for figuring that out!
PEB
 
Posts: 142
Joined: Sun Feb 21, 2010 2:28 am

Re: Simple Test Crashing on Windows

Postby airsoftsoftwair » Mon Jul 18, 2016 11:20 am

Requiring RapaGUI is necessary to use its functions but of course it shouldn't crash when not doing so. I'll add some error messages for that case.
User avatar
airsoftsoftwair
 
Posts: 2098
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany

Re: Simple Test Crashing on Windows

Postby airsoftsoftwair » Sat Nov 05, 2016 2:35 pm

Fixed now.
User avatar
airsoftsoftwair
 
Posts: 2098
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany


Return to RapaGUI

Who is online

Users browsing this forum: No registered users and 2 guests