Listview keyboard on MorphOS

Discuss GUI programming with the MUI Royale plugin here

Listview keyboard on MorphOS

Postby lazi » Wed Jun 28, 2017 9:39 pm

I have a listview like this:

<listview id="filelist" notify="active; doubleclick" Multiselect="None">

The cursor keys are working with the list on MUI5.0 OS4, but not on MorphOS.
Is there some settings in MUI/MOS or the xml which enables it or should I handle it by keyboard events?
User avatar
lazi
 
Posts: 273
Joined: Fri Feb 25, 2011 12:08 am

Re: Listview keyboard on MorphOS

Postby jPV » Thu Jun 29, 2017 9:06 am

Have you tried to activate the listview (clicking/tab) before using the cursor keys?
User avatar
jPV
 
Posts: 92
Joined: Sat Mar 26, 2016 11:44 am
Location: RNO

Re: Listview keyboard on MorphOS

Postby lazi » Thu Jun 29, 2017 10:12 pm

@JPV: Yes, tried it.

Running the MUI-Demo.hws and selecting the Listviews window in it, cursor keys are not working on my MOS installation.
Checked some MorphOS Preferences items and found that the listview gadgeds there are useable with keyboard.
I am quite unexeperienced in MOS, so don't know if it is a default feature or not.
User avatar
lazi
 
Posts: 273
Joined: Fri Feb 25, 2011 12:08 am

Re: Listview keyboard on MorphOS

Postby jPV » Fri Jun 30, 2017 8:46 am

Hmm.. true. The listview in the Listviews window doesn't work, but then the listview in the Strings window does work. It looks like that you need to activate the cyclechain and then keyboard controls do work.

This put to listview definition in XML seems to do the trick and then the Listviews demo works too:
cyclechain="true"

Bug or feature, I don't know :)
User avatar
jPV
 
Posts: 92
Joined: Sat Mar 26, 2016 11:44 am
Location: RNO

Re: Listview keyboard on MorphOS

Postby lazi » Fri Jun 30, 2017 10:42 pm

Many thanks!
Cyclechain does the trick.
User avatar
lazi
 
Posts: 273
Joined: Fri Feb 25, 2011 12:08 am

Re: Listview keyboard on MorphOS

Postby airsoftsoftwair » Sat Jul 01, 2017 10:21 pm

I don't know whether this is a bug or feature either but it certainly concerns MUI, not MUI Royale... so if you want some clarification, ask Thore by filing a ticket concerning this inconsistent behaviour over on http://muidev.de/ :)
User avatar
airsoftsoftwair
 
Posts: 2283
Joined: Fri Feb 12, 2010 3:33 pm
Location: Germany


Return to MUI Royale

Who is online

Users browsing this forum: No registered users and 3 guests